MPICH and gfortran

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

MPICH and gfortran

Mike Zingale
Can anyone provide info on getting MPICH 1.2.6 to configure and build with
gfortran?  I saw some reports on this list from Feb. but no instructions
were given.

In particular, I get this error when configuring:

configure: warning: Could not find a way to access the command line from
Fortran 77
configure: error: Command line access is required for MPICH
Error configuring the Fortran subsystem!
Turning off Fortran support

Is there a workaround for getting the command line access for gfortran (if
there is any) working with the MPICH configure?

Thanks,

Mike Zingale
Reply | Threaded
Open this post in threaded view
|

Re: MPICH and gfortran

Kamaraju Kusumanchi-3
On 6/14/05, Mike Zingale <[hidden email]> wrote:

> Can anyone provide info on getting MPICH 1.2.6 to configure and build with
> gfortran?  I saw some reports on this list from Feb. but no instructions
> were given.
>
> In particular, I get this error when configuring:
>
> configure: warning: Could not find a way to access the command line from
> Fortran 77
> configure: error: Command line access is required for MPICH
> Error configuring the Fortran subsystem!
> Turning off Fortran support
>
> Is there a workaround for getting the command line access for gfortran (if
> there is any) working with the MPICH configure?
>
> Thanks,
>
> Mike Zingale
>

mpich 1.2.6 is old according to
http://www-unix.mcs.anl.gov/mpi/mpich2/ . Please consider installing
mpich2. I have compiled mpich2 with gfortran and it works fine.

If you are further interested, you can join the mpich newsgroup (see
my signature) to discuss about your problems. I am ccing this email to
mpich newsgroup, so that others might be able to help you.

raju

--
http://groups-beta.google.com/group/mpich
Reply | Threaded
Open this post in threaded view
|

Re: MPICH and gfortran

Carsten Lemmen
In reply to this post by Mike Zingale
The following works for me

./configure --prefix=/opt --with-device=ch_shmem  --enable-cxx
--enable-f77 --with-mpe --with-arch=LINUX -with-f90 -fc=gfortran -cc=gcc
-f90=gfortran

Maybe you forgot to enable f77?

Cheers,
CL

Mike Zingale wrote:

> Can anyone provide info on getting MPICH 1.2.6 to configure and build
> with gfortran?  I saw some reports on this list from Feb. but no
> instructions were given.
>
> In particular, I get this error when configuring:
>
> configure: warning: Could not find a way to access the command line from
> Fortran 77
> configure: error: Command line access is required for MPICH
> Error configuring the Fortran subsystem!
> Turning off Fortran support
>
> Is there a workaround for getting the command line access for gfortran
> (if there is any) working with the MPICH configure?
>
> Thanks,
>
> Mike Zingale
>

--

Reply | Threaded
Open this post in threaded view
|

Re: MPICH and gfortran

Salvatore Filippone
In reply to this post by Mike Zingale

export F77_GETARGDECL=" "
export FC="/usr/local/gfortran/bin/gfortran"
export F90="/usr/local/gfortran/bin/gfortran"
export CC="/usr/local/gfortran/bin/gcc"

./configure --prefix=/usr/local/mpich-gfortran

works for me with 1.2.5.2 and 1.2.6.


--
Salvatore Filippone
Universit? di Roma Tor Vergata